Ongelmia käyttäjätunnuksen aktivoinnissa? Lue tämä ja lähetä sähköpostia sami (ät) motot.net.

SSL (https) sivusto ei oikein toimi...

Liittynyt:
25.5.2011 15:41
SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut TuttiX2 » 25.6.2015 11:57

Tulee mm. tuollaista virheilmoa....

Koodi: Valitse kaikki
[phpBB Debug] PHP Warning: in file /var/www/motot/public_html/talli/user.php on line 11: include(/var/www/motot/public_htmltalli/includes/functions.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file /var/www/motot/public_html/talli/user.php on line 11: include(): Failed opening '/var/www/motot/public_htmltalli/includes/functions.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
[phpBB Debug] PHP Warning: in file /var/www/motot/public_html/talli/user.php on line 12: include(/var/www/motot/public_htmltalli/includes/class_listing.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file /var/www/motot/public_html/talli/user.php on line 12: include(): Failed opening '/var/www/motot/public_htmltalli/includes/class_listing.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')
[phpBB Debug] PHP Warning: in file /var/www/motot/public_html/talli/user.php on line 19: set_error_handler() expects the argument (ads_msg_handler) to be a valid callback
Ylläpitäjä
Pyörä:
Cagiva Raptor 650
Paikkakunta:
Vantaa
Liittynyt:
27.9.2001 2:00
Re: SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut Sami » 25.6.2015 12:41

Https-osoitteiden pitäisi ohjata tavalliselle http-versiolle (https ei käytössä). Näköjään joissakin osioissa näin ei ole.
Ylläpitäjä
Pyörä:
Cagiva Raptor 650
Paikkakunta:
Vantaa
Liittynyt:
27.9.2001 2:00
Re: SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut Sami » 25.6.2015 12:48

Nyt vain http-version pitäisi olla käytettävissä. Https-version käyttöönottamiseksi tarvitaan enemmänkin muutoksia ja sitä ei ole odotettavissa ihan lähiaikoina...
tietoturva
Re: SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut tietoturva » 30.6.2015 10:52

Olisi kyllä tosi kiva jos laittaisitte https:n käyttöön edes kirjautumis-sivulle, jottei kuka vaan voi napata tunnusta/salasanaa avoimista verkoista.

ns. että esim. https://login.motot.net tms. toimisi pelkästään kirjautumiselle (jos niin haluaa ja linkin tietää) ja ohjaisi kirjautumisen jälkeen perus http-sivulle.
Ylläpitäjä
Pyörä:
Cagiva Raptor 650
Paikkakunta:
Vantaa
Liittynyt:
27.9.2001 2:00
Re: SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut Sami » 9.7.2015 18:58

Tämä on ollut ajatuksena, ei vaan ole toistaiseksi löytynyt aikaa tämän toteuttamiseen. Mutta tehdään tämän kesän aikana...
Ylläpitäjä
Pyörä:
Cagiva Raptor 650
Paikkakunta:
Vantaa
Liittynyt:
27.9.2001 2:00
Re: SSL (https) sivusto ei oikein toimi...

ViestiKirjoittanut Sami » 11.7.2015 20:25

Sivustolle on nyt hankittu signed serti ja kirjautuminen menee nyt https-sivun kautta (https käytössä ainoastaan sivulla jossa käsitellään login-lomakkeen tietojen vastaanotto).